TurboSite needs Java to run.